cancel
Showing results for 
Search instead for 
Did you mean: 
monaraya

Refresh Failure in Power BI Service with Error “Information Is Needed in Order to Combine Data”

Issue:  

Refresh Failure in Power BI Service with an error “Information is needed in order to combine data”. Desktop refresh works.

Error:

There was an error when processing the data in the dataset. Hide details.

Data source error: Information is needed in order to combine data; Information about a data source is required. The exception was raised by the IDbCommand interface. Table: XXX. Cluster URI: WABI-XXXXX-redirect.analysis.windows.net

Activity ID: XXXXXX. Request ID: XXXXX. Time: XXXX

Cause:

If the refresh in Power BI Desktop works with option "Always ignore privacy level settings" and throws a firewall error when other options are selected, then this refresh will not work in service since "Always ignore privacy level settings" is not available in Power BI Service.

s1.jpg

Resolution:

We changed the Privacy Level in Power BI Desktop: Global setting + Current File setting, such that it was not ignoring the privacy of data. We re-published the file to Power BI Service, updated the credentials to ‘Organizational’ in Power BI Service, and the issue was resolved.

Steps:

  1. We checked Privacy Level in Global setting as below: -

File -> Options and Settings -> Options -> Global -> Privacy -> Always combine data according to your Privacy Level setting for each data source.
Note: We need to first change Privacy for the Global settings, as shown below. If we directly go to Current File Setting (i.e. point 2), we will see the options are greyed out. We need to make sure we do not choose “Always ignore Privacy Level settings”, because this option is not available in Power BI Service, so refreshes on Power BI Service would fail.

s2.jpg

2. Similarly, we checked Privacy Level of Current File and have selected “Combine data according to your Privacy Level setting for each data source”.

S3.jpg

3. We changed the privacy level of each data source to “Organizational” as shown below:

    File -> Options and Setting -> Data source settings -> Edit Permissions -> Privacy set to Organizational.

s4.JPG4. Saved the report, refreshed on Power BI Desktop.

5. Published to Power BI Service.

6. Updated all the credentials and privacy setting in Power BI Service -> Dataset settings -> Data source credentials -> Sign in with Organizational as Privacy Level setting.

s5.JPG

7. The report refreshed successfully on Power BI Service.

Additional Reference: https://docs.microsoft.com/en-us/power-bi/admin/desktop-privacy-levels

 

Author: Srishti Sharma

Reviewer: Mounika Narayana Reddy

Comments

Thank you for this post! It was exactly what I needed today.

Hi @monaraya,

 

We are still experiencing the same error even we have follow through the resolution posted above numerous times.

 

How else can we overcome this issue?

 

same problem here...did the adaptations as mentioned above but no improvement.

Thanks for this post - this resolved the issue for me!

Polls
What is your favorite Power BI feature released this month?