cancel
Showing results for 
Search instead for 
Did you mean: 

Getting the correct Date Format to be displayed in the Power BI Service

Lately on the Power BI Community I have noticed people having issues with the date format not showing correctly. I thought I would post the steps on how to achieve this below.

 

This is how my date was formatted before making the changes below

image.png

NOTE: Before starting make sure you have saved and closed all your work. I had to sign out and sign back in for the changes to take effect.

  1. Click on the Windows Key and search for Language Settings
    1. image.png
  2. By default, this was set to English (United States)
    1. image.png
  3. To add a new language, I then clicked on “Add a preferred language”
    1. image.png
  4. I then searched for Australia and
    1. image.png
  5. I then clicked Next
  6. On the features page I selected all the options (Specifically “Set as my display language”)
    1. image.png
  7. And then clicked Install
    1. image.png
    2. I could then see it being installed
    3. image.png
  8. Once it was installed, I was then prompted that in order for the settings to take place I would have to sign out and sign back in
    1. image.png
  9. After logging out and back in again I went back to my language settings and I could see that it was now displaying “English (Australia)”
    1. image.png
  10. And now the format of my dates was as expected as shown below
    1. image.png

Summary

I have shown the steps to install the right language pack and have it running as the default, which will allow your Power BI dates to be displayed in the right format.

 

A shout out must go to ScottJackson_UK from the community who posted his initial findings which I used as a basis for this blog post.

 

And here is the link to his solution: Dashboard last refresh date shows in US format for users

 

Thanks for reading and any questions or suggestions most welcome in the comments section below.