Showing results for 
Search instead for 
Did you mean: 

Enabling the New Power BI Preview Web Part in SharePoint Online

Some of us have been waiting a long time for the new SharePoint Online Web Part for Power BI. Microsoft has released the announcement here along with a new video on how to use it. However, there are a few pre-requisites that are required in order to get to the point in the video where you can use the Power BI web part. This article covers those pre-requisites.


The important part of the video to pay attention to is that they use the Power BI web part on a "modern" or "Site Page". This is a new type of page that recently appeared in SharePoint Online. It's sort-of-kind-of like Publishing Pages but not really. In any event, if you can't create a "modern" page in SharePoint Online, you can't really use the new Power BI web part. I have checked both Wiki and Web Part Pages and the Power BI web part is nowhere to be found when editing those types of pages.


Checking if Site Pages ("Modern" Pages) are Enabled

To check whether or not you can create Site Pages, do the following:

  1. Navigate to any SharePoint Online site to which you have Contributor permissions or better
  2. Navigate to Site contents
  3. Navigate to Site pages
  4. Click the drop-down when creating an new page and you should see options for Wiki Page, Web Part Page, Site Page and Link

If you see Site Page, you are good to go, you can create a new Site Page and pick-up where the video starts. If not, read on.


Enabling Site Pages ("Modern" Pages)

The first thing to check are your Office 365 Tenant settings and SharePoint Online Administration settings. You will need administrative privileges to your tenant in order to perform these procedures.


Enabling First Release Features

  1. Navigate to and logon as an administrator
  2. On the left-hand side, expand Settings and then Organization profile
  3. Under Release preferences, make sure that the release track is First release for everyone or First release for selected users and that you are one of those users


Enabling SharePoint Online Preview Features

  1. From within the Office 365 administration portal, scroll down and expand Admin centers on the left-hand side and choose SharePoint
  2. Click over to the new tab that opens and on the left-hand side select Settings
  3. Scroll down until you see the option for Site Pages and select the radio button Allow users to create Site Pages
  4. Scroll down until you see the option for Prevew Features and select the radio button Enable preview features
  5. Scroll down and click OK


You should now be able to go back to your site and create a new Site Page and follow along with the video.


But I Still Can't Create Site Pages

OK, so while this should enable everything you need to get Site Pages and the Power BI preview web part working, at this point you may still not be able to create Site Pages. Couple things that could be going on here. One, if you just enabled these features, it may take a bit of time to become enabled in the tenant. So, wait a few hours or a day and then check again. However, it may also be an odd quirk that I have run into and fixed using the following process. Note, this process seemed to work on sites that had been created prior to all of the new features coming out, like "modern" pages. There may be variations to this process but this is what worked for me:

  1. Navigate to your SharePoint Online site
  2. Click the gear icon in the upper-right and then choose Site Settings
  3. Under Site Actions, click Manage site features
  4. If SharePoint Server Publishing feature is enabled, deactivate it
  5. Navigate back to managing site features and this time, deactivate the Wiki Page Home Page feature
  6. Navigate back to managing site features one more time and reactivate Wiki Page Home Page feature

Now you should be able to create Site Pages and follow along with the video.






Nice post Greg! Do you know of a way to get of the giant header in the "modern" pages? They push the reports down pretty far down.

I work with Greg, and we ran into the same issue with anohter site. The solution for this other site was a bit more involved, and I've detailed it here


@jramsey5 Currently SharePoint doesn't allow us to remove that header.  But I've heard it complained about in many Microsoft forums, so they are aware.

@Greg_Deckler This is a great guide, thanks! /Ruth

Hi Smoupre,


I am not able to enable this.


Can you please let me know.

How this is possible.


Thank you,



after adding the webpart and pasted the url of the the report, the webpart ask me to reconnect. 


Using fiddler and see a 400 error:


{"error":{"code":"10001","message":"Missing refresh token.","@error.redirectUrl":""}}


Anyone can help ?






I use SharePoint online with my company Office 365 account.


I created a Site page and embeded the Power BI report using Power preview web part. If I use the same account that I used to create the SharePoint embedding link from Power BI in SharePoint to login and view the Power BI report, all works well.

But, when another user in the organisation is accessing the page with his own credentials for Office 365 and trying to view the Power BI report, it is giving an error ""This content isn't available." The user has Power BI Pro licence.


Any suggestions why this may be the case?




Well, I've seen similar behavior, my guess would be that the new web part is still in preview so it is not fully functional as of yet. More of a demo at this point.

It was an issue with me as the creator of the Power BI report need to share it with the other staff who need to view the the report. @lukaszp helped to resolve this. Check this Link to @lukaszp answer.


"Missing refresh token" should be solvable by signing out of Sharepoint completely, closing all browser windows, then signing back in.