Reply
Highlighted
Tas Frequent Visitor
Frequent Visitor
Posts: 27
Registered: ‎07-23-2015

Row Level Security working in Reports but not Dashboard

I am finding the opposite of another post, though I am not sure our scenarios are the same.  

 

I have a dataset and report created in Power BI desktop with row level security, published to a Group in the service, with role memberships set up in the Group.

 

I then create a dashboard from an un-filtered page in the report, and share the dashboard.  When I login as a user who is subject to RLS filtering, and navigate to the shared dashboard, the dashboard remains un-filtered.  If I click through the dashboard to the report, the report initially displays un-filtered, but refreshes to display the correctly filtered results according to the RLS.

 

The doco indicates that RLS should apply in the shared dashboard but it does not seem to do so.

 

Has anyone got this working with shared dashboards?

Tas Frequent Visitor
Frequent Visitor
Posts: 27
Registered: ‎07-23-2015

Re: Row Level Security working in Reports but not Dashboard

OK, so I did some more testing, and found that if manually refreshed the shared dashboard as the logged in user subject to RLS, then it showed the correctly filtered data.  A shame it showed the unfiltered data first (which is not what we want the users to see!).

 

Seems like this may be a bug in sharing dashboards and RLS?  You would hope the dashboard updates the first time it is visited by the user and displays the limited data not the full set.

 

After this initial update of the dashboard, subsequent displays of seem to produce the right result.

Moderator
Posts: 2,546
Registered: ‎03-06-2016

Re: Row Level Security working in Reports but not Dashboard

@Tas

 

I can't reproduce your issue.

 

I test with SQL table data source, configure RLS in Power BI Desktop, publish it onto a Group and share the dashboard to another user within organization. It shows the limited data associated to that user only when initially displayed in both dashboard and click-through report.

 

What's data source in your scenario? And please verify the permission of the end users in your Group.

 

Regards,

Visitor
Posts: 1
Registered: ‎03-22-2017

Re: Row Level Security working in Reports but not Dashboard

[ Edited ]

I have the same or similar problem. When I open the report the filter doesn't seem to be in place, showing unfiltered data, but starting to drill down in my data the filter is there. After pressing refresh in PowerBi the filter works but reloading the report (F5) i see unfiltered data again. I'm connected to a tabular model on prem.

 

(When i talk about filter I mean the filter for the users Role in the tabular model)

 

My colleauge solved it. Removing the dataset and report and publishing it again solved the problem. Role security now works like a charm!

Tas Frequent Visitor
Frequent Visitor
Posts: 27
Registered: ‎07-23-2015

Re: Row Level Security working in Reports but not Dashboard

Simon,

 

The data source is SQL imported.  Updates are via gateway, but the model is hosted in the service.

 

The test user is in a Security Group, that is included in the RLS role.  The dashboard in question was created from an unfiltered report by me with no RLS filtering.

 

after logging in as the test user, the dashboard initially showed un filtered, but after manual refresh, and on subsequent views it was properly filtered by RLS, it is just the initial view that is in question.