Reply
Highlighted
Frequent Visitor
Posts: 3
Registered: Friday

NAV odata - organizational account

I'm trying to connect to my NAV 2017 deployment that is configured to authenticate with O365 but the Power BI desktop application is throwing the error message "The token service reported by the resource is not trusted"

 

I'm using Organizational account for the Odata feed.

Any help is appreciated.

Super Contributor
Posts: 835
Registered: ‎07-17-2016

Re: NAV odata - organizational account

Hi @NiSo,

 

To troubleshoot this issue, could you try connecting to Microsoft Dynamics NAV content pack on Power BI service with the same account by following steps from this article to see if the issue remains?Smiley Happy

 

Regards

Frequent Visitor
Posts: 3
Registered: Friday

Re: NAV odata - organizational account

Hi,

 

thanks for your reply.

Connecting to NAV using the content pack works fine.

But the difference is that using the NAV content pack, you can only connect with Basic authentication.

Where the Desktop APP supports the Organizational Account.

 

When I connect to the Odata using an organizational account, I do see outgoing traffic on the NAV server to (my assumption would be O365 login page?) and then the error is thrown in the BI client. Logging in with the MS Dynamics NAV client works fine using O365/organizational account credentials.

 

I have tried 2 different approaches, using the common Azure AD authentication page in the NAV setup and using the dedicated Azure AD. Both work fine for the NAV client, but Power BI returns the same error when clicking on the "sign in" button.

 

NiSo.

Frequent Visitor
Posts: 3
Registered: Friday

Re: NAV odata - organizational account

Once I changed the value TokenAuthorityEndpoint on the NAV server to the endpoint for my Azure AD, I now get prompted with the credential box for WAAD. But after authentication it is not able to find the "registered application" with the URL name of my NAV server. Not sure wherepower BI specifies this app name? 

 

In meantime I have reported a call at MS premier support.