Reply
Member
Posts: 85
Registered: ‎03-17-2016

Filter does not show data on Power BI Service but works fine on Desktop

Hello all;

 

Thanks for looking at my post. I have a strange issue that the filter works fine on the Desktop version. That is if i click a bar from one chart, it shows the details on Details Analysis table just fine.  Please see the screen blow.Normal Working Condition.jpg

 

However, it does not work on Power BI Service (on the cloud). It does not give me any data when i clickec on the bar chart above it. 

 

Error Screen.jpg

 

Please let me know if you could help me with this. I have checked all the filter and even redeployed Power BI from Desktop to the cloud. 

 

Thanks;

Andrew

 

Super Contributor
Posts: 3,784
Registered: ‎05-02-2017

Re: Filter does not show data on Power BI Service but works fine on Desktop

@AndrewDang

 

Hi Andrew,

 

Could you please share your PBIX file? You can delete the confidential parts first. I can't reproduce your issue. 

 

Best Regards!

Dale

 

Highlighted
Frequent Visitor
Posts: 2
Registered: ‎11-13-2017

Re: Filter does not show data on Power BI Service but works fine on Desktop

Maybe it might be helpful for some future reader...

I had the same issue. Filters working in Desktop but not Cloud (partially some records were filtered correctly). After some investigation I found that I used a type conversion from a value like "DD:MM:YYYY hh:mm:ss.milliseconds" to Date/Time which worked visually in Desktop and Cloud. 

After eliminating the milliseconds part the filters started working. I just can assume that the conversion somehow broke some future processing of the records.

 

Best regards

 

Sebastian