Reply
Highlighted
Member
Posts: 55
Registered: ‎11-09-2015
Accepted Solution

Dates show as (Blank) in app.powerbi.com, but not in Desktop

Hi,

 

I have a problem with a report where on the app.powerbi.com service, it continually loses it's date reference. It replaces every date reference to "(Blank)".

 

It does NOT do this in the Desktop version.

 

When I publish it to the app.powerbi.com site, it keeps the date until you move to another report, then back again (or press the refresh button).

 

The date table is being pulled from the same server on a different database. However, it connects and pulls data fine.

 

Has anyone else had this problem? - Highly annoying!!!

 

Thanks,

James


Accepted Solutions
Member
Posts: 55
Registered: ‎11-09-2015

Re: Dates show as (Blank) in app.powerbi.com, but not in Desktop

I have resolved the issue.

 

For some reason, adding the "Date" > "Month" > "Month of Name" column via the "Add Column" in Query Editor caused the problem.

 

Fix:

(My Date Table already has a Month Number)

I added a conditional column that looked at the Month number (i.e. 4) and made the output "Month Name" (i.e. April)

 

ConditonalMonth.PNG

 

 

Report refreshes fine and keeps the Month Name in the report.

View solution in original post


All Replies
Moderator
Posts: 1,937
Registered: ‎03-06-2016

Re: Dates show as (Blank) in app.powerbi.com, but not in Desktop

@jameslo30

 

I haven't reproduced your issue.

 

7.PNG

 

8.PNG

 

 

What's your data source? What's the data type and format of that date column in your source?

 

Can you share some screenshots?

 

Regards,

Member
Posts: 55
Registered: ‎11-09-2015

Re: Dates show as (Blank) in app.powerbi.com, but not in Desktop

Hi Simon,

 

Thanks for your reply.

 

The data source is read from a local SQL server database using the Data Gateway Connector.

See screenshot below for the date types

 

Hopefully you can see this 

 

Picture 1. PowerBI Desktop (values are fine)

Problem1.png

 

 

Picture 2 Date Table

Problem2.png

 

Picture 3 - PowerBI Web (missing values)

Problem3.png

 

 

When I re-publish the report, the values show up for about 10 seconds, until you switch reports and come back to it. They then disappear!

 

Any ideas?

 

Thanks,

James

Member
Posts: 55
Registered: ‎11-09-2015

Re: Dates show as (Blank) in app.powerbi.com, but not in Desktop

Actually, I've just noticed it does it on a Data Refresh rather than switching between reports. It's almost as-if it gives up half way between collecting the data? - Although it's a successful refresh. 

Member
Posts: 55
Registered: ‎11-09-2015

Re: Dates show as (Blank) in app.powerbi.com, but not in Desktop

I have resolved the issue.

 

For some reason, adding the "Date" > "Month" > "Month of Name" column via the "Add Column" in Query Editor caused the problem.

 

Fix:

(My Date Table already has a Month Number)

I added a conditional column that looked at the Month number (i.e. 4) and made the output "Month Name" (i.e. April)

 

ConditonalMonth.PNG

 

 

Report refreshes fine and keeps the Month Name in the report.