Reply
Frequent Visitor
Posts: 2
Registered: ‎04-20-2017

Can't connect to redshift via service

I can connect to redshift with desktop but not via the service.  I think I added the correct IP address.  Our cluster is configured with force_ssl=true, if that matters.  Getting this error:

 

The credentials you provided for the data source are invalid. Please check the credentials for all the data sources.

Activity ID:1525d65b-6f61-bcfd-336b-2e203c61a4d9
Request ID:469a52ea-77e4-95a4-c24f-21c557bf7f16
Status code:400
Time:Thu Apr 20 2017 21:03:04 GMT+0300 (Jerusalem Daylight Time)
Version:13.0.1700.1829
Cluster URI:https://wabi-brazil-south-redirect.analysis.windows.net

 

Moderator
Posts: 1,666
Registered: ‎03-06-2016

Re: Can't connect to redshift via service

@molbit

 

As the error message said, you credential is not valid. You need to edit the credential in Datast Settings. For more details, please see: Announcing support for Amazon Redshift connectivity in the Power BI service

 

Regards,

 

 

Frequent Visitor
Posts: 2
Registered: ‎04-20-2017

Re: Can't connect to redshift via service

I don't think that's the problem.  I don't see any new entries in STL_CONNECTION_LOG after creating credentials and connection attemp.  Like I said, I'm pretty sure the ip address is correct.

 

Whereas in desktop, the connection is successful and appear in STL_CONNECTION_LOG.  Though in desktop it gives a warning says, "source doesn't support encryption" even though force_ssl=true.  (Not sure if that's related.)

Frequent Visitor
Posts: 10
Registered: ‎05-10-2017

Re: Can't connect to redshift via service

Did anyone solve this? Even I get the same error