New Idea
0 Kudos



We are working with our client on a Power BI project and we are facing a one issue with the Power BI currently.

The developer of the cube has created a data cube for us to use in the Power BI and we have connected to that with live data.


Now when report and all has been done, we would like to have feasible report \ dashboard in use for the future, without user always updating manually the weeks\dates in use on the visual. But this can't be achieved 'cause we are using string dates.


Well at least that was the case until the cube developer told that the dates are actually in date forman in the ssas cube already.

For some reason power bi handles those dates as a string.


We need to have a dynamic date filtering that did come available with the July 2017 power bi update with a date field in place soon. But for reason Power BI handles the date as a string....?


The developer is now going to try something like this fix, to see if we can figure this out:






Status: Needs Info
0 Kudos

Usage metrics not generating

Status: Delivered
by samdthompson Established Member on ‎08-02-2017 07:53 PM
Something went wrong
We're having trouble loading usage metrics right now.
Please try again later or contact support. If you contact support, please provide these details.
Activity ID8911897b-9bfa-492d-ac4e-c20aed0684e2
TimeThu Aug 03 2017 14:51:06 GMT+1200 (New Zealand Standard Time)
Correlation IDb7a3e451-1f6f-582b-1e56-73e039121c82
Status: Delivered
0 Kudos

Limit of uncompressed data has exceeded

Status: New
by esequielv Occasional Visitor on ‎08-02-2017 07:38 PM

Hi everyone,

I have a DashBoard where I loaded 9 csv files. The sum of the sizes is 6.26GB. It means the uncompressed size.

I load this files with less data in order to publish the dashboard in my work space and I created a Data Set to load this files.

My Workspace has 9,5GB free. And when I tried to refresh the data set I got the following message:

"The received uncompressed data on the gateway client has exceeded limit."

But, how I said, the sum of the files size is 6.26GB. It's not more than 10GB.

I don't know what to do to fix this problem once I read the Power BI documentation and it shows a size limit of 10GB of uncompressed files.

Anyone can help me?


0 Kudos



I use Power Bi with 'MS-SQL, Oracle' DBMS in company.

At this time, we got a new DBMS in 'PostgreSQL'. Fortunately,I success connect datasource and load database and doing my own job in Power BI DESKTOP. but since i tried to setting gateway service on Power BI Web portal, have big problem as below.



Step1. Connecting Power BI Web portal(


Step2. Manage Gateways


Step3. 'Add Data Soruce' then input PostgreSQL setting parameters which exact the same as Power BI Desktop connection parameters (ex: server, database, ID, password).


Then, i got a error message as below.


이미지 159.jpg
































in order to error message by microsoft, feedback to me, I did not install  'Npqsql'.

but i already installed 'Npqsql'.if not, definitely, it does not work in 'Power Bi Desktop' also. so i thinks this feedback is incorrect.


so i search information in Power BI Community forum.  lastest NPQSQL is not supported. so i re-install NPQSQL 3.2.2.

but it does not still works..


please let me know what i have to do for solving this issue.


your advise will be very appreciated.

Status: Needs Info
0 Kudos

Gateway problems update august 2017

Status: Accepted
by vivianaflorez Visitor on ‎08-02-2017 04:19 PM



I had some reports connected to sql server in azure without problems, since I update gateway (version: 14.16.6390.2 ), I received this message:


Underlying error code:


Underlying error message:

The server name provided doesn't match the server name on the SQL Server SSL certificate. Please see (Source at XXXXX;YYYYYY.)


The server name in the certificate is the same that configuration. This problem is new. Please help me. I tried change the server name for IP and it didnt work.


Also, problems is just with sql server, other sources works fine.



Status: Accepted
0 Kudos

I created a workspace, then deployed it as a Power BI app.


Worked great, I made some adjustments, published it a few more times updating the app each time.  Zero issues.


Now I went and added a few more users to the access list and went to update the app again... it goes "publishing app" spins and then errors out:




Has anyone else had this?


My other apps seem to update just fine.


I also tried deleting the workspace image file it was using, as a few other posters had mentioned that helping.


Still no good Smiley Sad

Status: Accepted
0 Kudos


I have a model that is using a deployed Power BI model as a data source. On one page that has (new) Matrix visuals, I see different behaviour between Power BI Desktop and the web service. On the desktop, clicking one of the Slicer members filters all four Matrix visuals properly. But on the web, clicking the same Slicer member only filters TWO of the four matrix visuals.


Screen shot is included but the resolution may be bad. On the right is the Desktop, on the left is the Service. On each, notice the first and third matrix visuals on the respective left side of the canvase.




Status: Delivered
0 Kudos

Error message in pbi desktop

Status: Accepted
by fdenblanken Occasional Visitor on ‎08-02-2017 09:48 AM

LS, when opening my Power BI reports and when switching to different pages, I regularly get the error described below. I sent a frown and your colleague requested me to open a ticket online. Not sure what to write as a summary as I get an error message that I don't understand. My colleagues have the same issue. We do not get the error in all our power bi reports.

Note that I could not upload all error data.


Hope you can help. 


Thanks and regards,




Data to send to Microsoft:

Feedback Type:
Frown (Error)


Local Time:

Product Version:
2.48.4792.721 (PBIDesktop) (x64)

July 2017

IE Version:

OS Version:
Microsoft Windows NT 10.0.14393.0 (x64 es-ES)

CLR Version:
4.6.2. or later [Release Number = 460805]

Workbook Package Info:
1* - en-GB, Query Groups: 1, fastCombine: Disabled, runBackgroundAnalysis: True.

Peak Working Set:
1.03 GB

Private Memory:
0.996 GB

Peak Virtual Memory:
34.7 GB


JS Error Message:
Script error.

Error Message:
An error occurred while rendering the report.

Stack Trace:
Microsoft.Mashup.Host.Document.JavaScriptException: An error occurred while rendering the report.
at :line 0

Invocation Stack Trace:
at Microsoft.Mashup.Host.Document.ExceptionExtensions.GetCurrentInvocationStackTrace()
at Microsoft.Mashup.Client.ClientShared.FeedbackErrorInfo..ctor(String message, Nullable`1 errorCode, String requestId, Exception exception)
at Microsoft.Mashup.Client.ClientShared.UnexpectedExceptionHandler.<>c__DisplayClass1.<HandleException>b__0()
at Microsoft.Mashup.Host.Document.SynchronizationContextExtensions.<>c__DisplayClass3.<SendAndMarshalExceptions>b__0(Object null)
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Delegate.DynamicInvokeImpl(Object[] args)
at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
at Microsoft.Mashup.Client.ClientShared.WindowManager.ShowDialog[T](T form, IWin32Window owner)
at Microsoft.PowerBI.Client.Program.<>c__DisplayClassd.<Main>b__0()
at Microsoft.Mashup.Host.Document.ExceptionHandlerExtensions.HandleExceptions(IExceptionHandler exceptionHandler, Action action)
at Microsoft.PowerBI.Client.Program.Main(String[] args)

User ID:

Session ID:

Telemetry Enabled:

Model Default Mode:

Snapshot Trace Logs:
C:\Users\florus.denblanken\AppData\Local\Microsoft\Power BI Desktop\

Performance Trace Logs:
C:\Users\florus.denblanken\AppData\Local\Microsoft\Power BI Desktop\

Disabled Preview Features:

Disabled DirectQuery Options:


DPI Scale:

Status: Accepted
0 Kudos

Unable to create a work space

Status: Delivered
by amodpandit Occasional Visitor on ‎08-02-2017 08:11 AM

I am on a trial version of PowerBI Pro and it does not allow me to create a workspace giving an error saying "Something went wrong"

Status: Delivered
0 Kudos

JIRA + Power BI not connectable

Status: Delivered
by thomas_landuyt New Member on ‎08-02-2017 07:35 AM



I'm currenlty new on Power BI and I'm trying to connect our JIRA instance with the power BI (get-data).


This is currently working for anonymous authentication but not for basic or windows authentication. This keeps on loading(for hours +24h) and nothing happens . On the desktop app with the content pack we have the same issue. The only difference is that it goes in timeout after a while.


Do you have any idea what can be the reason?

Status: Delivered
0 Kudos

None of my tiles are loading

Status: Needs Info
by cigillis New Member on ‎08-02-2017 06:51 AM

I am getting the following error on all of my tiles



Status: Needs Info
0 Kudos

Odata feed with $select statement

Status: Accepted
by ruimonteiro Frequent Visitor on ‎08-02-2017 06:11 AM



Trying to get data from dynamics with an odata feed and selecting only one column at server.

The result includes all the columns from the source. 




 Any help would be appreciated.


Thanks in advance.




Status: Accepted
0 Kudos

I have a text box that is all underlined and bold.  


I then take the formatting of some of the text and it is ok.


I then navigate to another tab in desktop mode and then back again and the formatting is back.



Status: Delivered
0 Kudos

When I add a tile to a dashboard with a custom link to a report in the current workspace, the link works fine. However, when the dashboard is shared with a user who isn't a member of the workspace, the tile doesn't seem to respond at all, although the pointer changes to the hyperlink hand.

I'd expect having a custom link to a report in the current workspace would provide access to that report to users the dashboard is shared with.

Status: Accepted
0 Kudos

Hourly grouping Bug

Status: Needs Info
by C_Houghton Visitor ‎08-02-2017 01:12 AM - edited ‎08-02-2017 01:13 AM

I've got a Data/Time column and I'm grouping by 1 hour chunks. On the same page I have a stacked column of time vs quantity of tickets logged at that time. I also have a table that shows the details of all the tickets received in the selected hour. The hours along the axis of the bar chart go something like ' ..... 8:00, 9:00, 9:59:59, 11:00, 12:00, 12:59:59 , 2:00, 3:00, 3:59:59 .....'.  For all the hours ending in :00, when the column is selected the data for the tickets displays correctly in the table below, but for the hours ending in :59, no data is displayed in the table below when you select those hours. Seems like a bug to me, unless someone knows otherwise.  


As previously said, the bins are 1 hour and no other customisation is available. 


Any thoughts?

Status: Needs Info
0 Kudos

I have a report which I renamed in the online service.  I then downloaded the report added a change, but when I reuploaded it instead of overwriting the old one it created a new instance and becasue of that doesnt allow me to update the content pacl.





Status: Needs Info
0 Kudos

Table join issue in modeling layer

Status: Needs Info
by rossgerber Frequent Visitor on ‎08-01-2017 03:54 PM

I have a mapping table that has two values





When joining to my fact table, I am getting the error that there "unique values are required in one table.  Once I remove the "GREEN " row then the join works.  


Power BI seems to be dropping the " " when I try to join.  My data type is set to ABC and I see the space in the query editor.  Please fix this issue.  

Status: Needs Info
0 Kudos



I m trying to schedule data refresh for a data-set that uses Salesforce and Excel using On-premises gateway.


While I m able to configure the same using the latest gateway(Personal Mode), the option to select on-premises data gateway is disabled.(It is running fine on a different local machine and I have configured other data sources for refresh)


Salesforce prompts for authentication using OAuth2 while Windows Authentication is enabled for Excel.


* Does on-premises gateway (July 2017 update) support Salesforce?


* I m fine changing excel to a different data source like Azure SQL DB/ SQLS erver if necessary. But is there a work around that I can use that would enable me to use on-premises gateway instead of personal gateway.


* I have also come across articles that mention lack of support for salesforce/ OAuth2 with other Data Sources.  If it has anything to do with the feature implementation on on-premises gateway, it would be nice if someone from microsoft can comment on any plans regarding when the support for salesforce can be expected.






0 Kudos

I have streaming dataset as a sink output of an ASA job. Occasionaly I get similar send errors like shown below in the ASA job.
        "Message": "There was a problem sending data to Power BI. The following information may be helpful diagnosing the issue. Power BI ReferenceId: 50472c19-4d3d-4079-bb82-1480005acedd. PushDataAsync error [An error occurred while sending the request.] with request Id [50472c19-4d3d-4079-bb82-1480005acedd]. Error encountered after writing [93] batches. Error - An error occurred while sending the request.\r\n- The underlying connection was closed: A connection that was expected to be kept alive was closed by the server.\r\n- Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.\r\n- An existing connection was forcibly closed by the remote host\r\n",


I've submitted a support ticket (REG:117021715339692) to the ASA team and the conclusion is that this is caused by some internal Power Bi activities. Is it possible to get rid of these errors as it's triggering nuisance alerts?

0 Kudos

A really small bug. When you right click on a view or table the menu load/edit pops up but it hides the Navigator pane. See video voor reproducing the bug.

Status: Needs Info
Idea Statuses