0 Kudos

data refresh issue - unsupported data source

Status: Delivered
by celebrindal Frequent Visitor on ‎03-17-2017 08:01 AM

Hi all. When posting a dataset to a group so that I can enable row level security I get this error.

 

It's connecting to our PWA server using oData connectors. Works fine internally just not working in this group.

 

As a side point the RLS doesn't seem to work either but I have a feeling it might be related to the dataset not refreshing back to the database to check security?

 

Capture.JPG

Status: Delivered
Comments
by Moderator v-qiuyu-MSFT
on ‎03-19-2017 08:08 PM

Hi @celebrindal,

 

Please publish the report to My Workspace or other group workspace and refresh to see if the same error occurs. Also please try to republish the report to this specific group.

 

Best Regards,
Qiuyun Yu

by Moderator Vicky_Song
on ‎03-19-2017 08:09 PM
Status changed to: Needs Info
 
by celebrindal Frequent Visitor
‎03-20-2017 08:15 AM - edited ‎03-20-2017 08:24 AM

Hi yes I've verified now that none of my oData reports are working no matter where they are published.. they work fine from the desktop but refuse to refresh online.

 

This is both for and not datasets that have row level security enabled.

by Moderator v-qiuyu-MSFT
on ‎03-21-2017 02:08 AM

Hi @celebrindal,

 

For this issue, I would suggest you create a support ticket to get dedicated support.

 

Best Regards,
Qiuyun Yu

by Moderator Vicky_Song
on ‎03-21-2017 02:09 AM
Status changed to: Delivered
 
by celebrindal Frequent Visitor
on ‎03-22-2017 12:36 PM

Thanks ticket submitted.

by sasmpu00 Frequent Visitor
on ‎05-19-2017 07:58 AM

Seems like, you are using custom function call web URL. If it is , please follow the instruction mentioned in below URL. you may need to split URL into two parts - main url and relative path. 

 

https://blog.crossjoin.co.uk/2016/08/23/web-contents-m-functions-and-dataset-refresh-errors-in-power...