0 Kudos

Row level Security not working

Status: Delivered
by celebrindal Frequent Visitor on ‎03-20-2017 04:20 PM

Hi, new to the attempt at Row level security so I'll be the first to admit that I've got something setup wrong but here is what I'm seeing so far.

 

I have created the Role in the desktop mode, and when I test it as the user i'm connecting as on the desktop it filters down correctly.

 

I have created a group in Powerbi web and I have done the following:

Published the report to the group.

Pinned the whole report page to the group as a dashboard.

Invited my test account to the dashboard.

In the security setting on the dataset i've add the test account to the Role. Adding in the email address that was included in the group. xxxxx@xxxx.com

When I go to the sharing link that is emailed to that test account I get a 'the data shown in this tile is no longer available, Please contact the report owner for details.'

 

At first I thought it might have been that my report was using oData to connect to a PWA system. (it's not allowing the dataset to refresh, see other post...)

So I created a new report based off of something else that is connecting to a database. And it refreshes fine, connects to the gateway etc.. but still no dice.

When I had an external user attempt this they at least saw the tiles but everything was x'd out like it wasn't getting their role to show them the proper data. (that's on the oData one.)

 

When you click on the elipses to go to the report I get a something went wrong error.

Something went wrong

Unable to load report
Please try again later or contact support. If you contact support, please provide these details.
Activity IDb89b66e7-b907-44ee-b8dd-1893f60f74d1
Request ID4d0d5a89-e041-46f2-a610-a0c7506733ac
Correlation ID46b8b349-b1cc-705d-2e11-f815af792d9b
TimeMon Mar 20 2017 16:18:04 GMT-0700 (Pacific Daylight Time)
Version13.0.1700.1439
Cluster URIhttps://wabi-west-us-redirect.analysis.windows.net/

 

If I close that, it opens up the report window, with a bit almost done and circles moving around.. which stays there forever..

 

So thoughts, or a bug?

 

Thanks.

Status: Delivered
Comments
by v-haibl-msft Super Contributor
on ‎03-22-2017 12:02 AM

@celebrindal

 

I tried to share dashboard (RLS enabled) to internal user and it worked properly, the shared user can only see the filtered data.
You should not share dashboard (RLS enabled) to external user, since you cannot add external user to any role in Security.

Please try to validate the role within the Power BI service according to this document.

 

Best Regards,
Herbert

by Moderator Vicky_Song
on ‎03-22-2017 12:03 AM
Status changed to: Needs Info
 
by celebrindal Frequent Visitor
on ‎03-22-2017 12:37 PM

Thanks Herbert. Tested the same internally and yes it seems to work.

 

Any word on when this will be available to external users? Need that more than internal users ;-)

by v-haibl-msft Super Contributor
on ‎04-11-2017 03:10 AM

@celebrindal

 

There is no ETA for external users. I think you can create an idea in https://ideas.powerbi.com for it.

 

Best Regards,
Herbert

by Moderator Vicky_Song
on ‎04-11-2017 03:10 AM
Status changed to: Delivered