0 Kudos

Query execution failed due to an invalid column or object name.

Status: Needs Info
by DaHa Frequent Visitor on ‎03-17-2017 08:39 AM

Hello,

Has anyone seen the above message before in published reports which work OK in the Desktop Program?

 

  • The published reports were working OK yesterday and nothing in the report changed since, however the data is loaded to the SQL server we are querying overnight from a production system.
  • Nothing is reporting as wrong on the Gateway.
  • Other reports using the same SQL query and similar custom measures/columns etc. are working OK.
  • Tried saving/republishing/saving as a different report/republishing which didn't work.
  • Full error message text is: DM_GWPipeline_Gateway_InvalidObjectNameException and this doesn't come up with much using Google-Fu.

 

Current thinking is a dodgy record somewhere in the query overnight is playing havoc on the Gateway.

Any ideas other than leaving it to rest and sort itself out over the weekend greatly appreciated?

 

Cheers!

DaHa.

Status: Needs Info
Comments
by Moderator v-qiuyu-MSFT
on ‎03-20-2017 02:06 AM

Hi @DaHa,

 

I found the same issue reported: CRI 33107807. PG said

 

“As mentioned, this error is coming to us from the server. We are merely surfacing it. Please have the customer check their SQL logs to determine what the precise issue is.”

 

So in your scenario, please contact with your SQL Server administrator to check SQL logs at the time that the error throws out.

 

Best Regards,
Qiuyun Yu

by Moderator Vicky_Song
on ‎03-20-2017 02:07 AM
Status changed to: Needs Info
 
by DaHa Frequent Visitor
on ‎03-20-2017 04:01 AM

Thanks very much will look into this area.

DaHa.

by DaHa Frequent Visitor
on ‎03-21-2017 04:01 AM

Just to follow up on this, issue resolved.

SQL Server Admin could see errors when the query was being executed by the Gateway. Parenthesis were being added to one of the SQL queries causing it to fail and exhibiting this issue. Deleted and recreated the query from scratch and this solved the problem.

DaHa.