Power BI Gateway - Personal error - GWConf has stopped working

Status: Needs Info
by johnahrens19 Visitor on ‎03-10-2017 07:04 AM

This morning, when I started Power BI Gateway - Personal, it failed with the error, "GWConf has stopped working A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."  I uninstalled and re-installed the application but am still getting the same error.  The Personal gateway as worked flawlessly for weeks prior to today.  I'm not aware of any changes being made to my PC but I'm using a company computer and sometimes our IT department pushes out updates without prior notification.  Where do I begin looking for the cause of the failure? (I'm just a Power BI user, not a developer.)

Status: Needs Info
Comments
by stayup_artist Frequent Visitor
‎03-10-2017 01:19 PM - edited ‎03-10-2017 01:21 PM

I was able to get around the issue.  Here is how I did it (some part of it may not make sense or necessary, but not clue which)

 

1. go to C:\Users\your user name\AppData\Local\Power BI Gateway - Personal\2.0\Configurator folder and find file "ConnectorConfig.xml"

2. Use text editor to open it and change the line #8

    <GlobalServiceEndpoint>https://api.powerbi.com</GlobalServiceEndpoint>

to

    <GlobalServiceEndpoint>https://app.powerbi.com</GlobalServiceEndpoint>

close the file from text editor.

That was me just blindly guessing if this address was incorrect, but

3. Run the gateway, this time when I click "login to powerbi.com" or hit next, it didn't crash with GWConf error, it went next step saying something is incorrect.... well of course, but it did not crash.

4. In Text editor and change back from "app" to "api" in that line. close it.  Now open gateway, it works for me!

 

Let me know if it works for you.

 

Rick

 

by acabrera Frequent Visitor
on ‎03-13-2017 06:26 AM

Have someone resolved the problem, I need urgently to update my data

by v-haibl-msft Super Contributor
on ‎03-14-2017 01:19 AM

Hi All,

 

Does this issue persist, or it has been resolved now?

 

Best Regards,

Herbert

 

 

by Moderator Vicky_Song
on ‎03-14-2017 01:20 AM
Status changed to: Needs Info
 
by johnahrens19 Visitor
on ‎03-14-2017 06:24 AM

Microsoft appears to have fixed this issue by 4 PM PST on 3/10/17.  The problem was listed on the Power BI Issues page for several hours.  When the issue listing went away late in the day, I tried the Personal Gateway and found it to be working again.  The operation is slightly different now, however.  Formerly, when I booted my computer, I would be prompted to log in to my Personal Gateway.  That log in prompt no longer appears but the Personal Gateway appears to be working fine.  I can refresh my reports with no problems.

by yash1105 Frequent Visitor
on ‎03-14-2017 06:32 AM

Looks like it is fixed, I am able to refresh my reports when came back on Monday.

by paulw Frequent Visitor
on ‎03-14-2017 07:52 AM

i have still having the same issue.  any ideas would be welcome.

thank you

by paulw Frequent Visitor
on ‎03-14-2017 07:57 AM

same problem for me.  not resolved yet.

 

i am refreshing from excel files.  is that consistent to all having the problem?

Idea Statuses