0 Kudos

Custom URLs Dont work and documentation is not clear

Status: New
by Tas Frequent Visitor Monday

I can not get Custom URLs to work  I have tried following the documenation here, in the section on 

Share a filtered version of a report

 

But it provides 3 steps and is not clear whether all three are required, or steps 1&2 are alternatives.  The example for Step 1 does not match the word description, is not clear about whether the report should be saved with the filter (which doesnt make sense) and Step 2 offers a completely different example to step 1.

 

I have tried all of these steps and can not get a custom URL to work for a report created in PBIDT and published to the service.

 

Please make the documentation on this clear, concise and consistent.

Comments
by Tas Frequent Visitor
Monday

After more trial and error, I have discovered that Undescores are not supported in either table or column names. Also it seems the value has to be quoted. Single quotes work, which convert to %27 in the URL. These should be included in the doco, or preferably fixed in the service.

Step 1 in the doco is misleading. Ignore it unless you plan to save a copy of the report, pre filtered and share it. For the custom URL, the table /column does not already have to exist as a page or report filter, it just has to be in the model, and related to the data you want to filter.

Unfortunately, if you construct the custom URL, and then try to use it as the URL for a dashboard tile, the service ignores the filter part. This is very annoying, and relates to other ideas posts asking for tiles created from filtered or sliced reports to reinstate the filter or slices when you click through from the tile to the report. So no viable workaround for that annoying behaviuor yet.

by Moderator v-qiuyu-MSFT
Tuesday - last edited Tuesday

Hi @Tas,

 

Thanks for your feedback about the official online document. I will contact the author internally, will update here once I get any information.

 

To format the report URL, we can use it this format: <report page URL>?filter=<tablename>/<fieldname> eq '<value>'. Remember the value should be quoted by the single quotes.

 

In this example we're filtering the Retail Analysis sample, if the report page URL is

https://app.powerbi.com/groups/me/reports/a8530b78-0506-48f4-97ce-56aef187ecca/ReportSection3

 

the filtered report URL can be formatted as

 

https://app.powerbi.com/groups/me/reports/a8530b78-0506-48f4-97ce-56aef187ecca/ReportSection3?filter... eq 'NC'

 

If the table name has underscores, you can also use this format. Assume report page URL:

https://app.powerbi.com/groups/me/reports/8cbaa75b-40bd-4c7c-8582-b90feafc6fe6/ReportSection

 

the formmated URL can work fine:

https://app.powerbi.com/groups/me/reports/8cbaa75b-40bd-4c7c-8582-b90feafc6fe6/ReportSection?filter=... eq 'Europe'

 

 

It will display the report data filtered when Territory is ‘NC’. When we use this formatted URL as custom URL for the dashboard tile, when we click the tile go to the report, report data will be filtered.

 

Please test for the Retail Analysis sample as the custom URL we provided to see if it will display filtered report when we click the dashboard tile.

 

Best Regards,
Qiuyun Yu

by Tas Frequent Visitor
yesterday

Qiuyun,

 

Thank you, but I don't see anything in your example for table name including underscores that is different.  You just indicate the same format ... eg 'Europe'.  This does not illustrate anything different. Can you please provide a complete example for the filtered URL?

 

I have not been able to get any filtered URLs to work as the custom URL for a dashboard tile.  Could it be that the dashboard tile has to be created from the report with the filtered URL already used, so that we don't specify a custom URL?  Or is the custom URL supposed to honour the filter if specified?

 

thanks.

by Tas Frequent Visitor
yesterday - last edited yesterday

@v-qiuyu-MSFT,

 

Here is a test using the Retail Analysis sample.

 

Dashboard Tile Custom URL:

https://app.powerbi.com/groups/60464442-9109-446e-b2f2-58c47ab52088/reports/cd849292-9a8d-4359-ab45-...

 

Resulting Report on click through.

URL: https://app.powerbi.com/groups/60464442-9109-446e-b2f2-58c47ab52088/reports/cd849292-9a8d-4359-ab45-...

(ie no filter is applied)

 

I have not been able to get a custom URL with a filter to work on any dashboard tile I have tried.

 

Report output is not filtered.

 

EDIT:

 

I did test whether creating the tile from the report displayed with the URL filter already in place makes any difference, and it did not.

 

I have just tested a new tile with this Custom URL:

https://app.powerbi.com/groups/60464442-9109-446e-b2f2-58c47ab52088/reports/cd849292-9a8d-4359-ab45-...

 

and this one works.   However no other example has worked so far, so clearly there is still something either missing from the instructions, documentation, or there is an error in the service in some use cases.  I need to get to the bottom of this issue, so I can give my users a sensible outcome.

 

I note that the difference in this latest test case is that the filter has no spaces in any part except around the 'eq' :

?filter=Store%252FTerritory%20eq%20%27NC%27

 

Where the first example above has spaces inside the value 'FD - 01':

?filter=District%252FDistrict%20eq%20%27FD%20-%2001%27

 

However in my own examples, my filters dont have any spaces or underscores any more, and they still dont work as custom URLS.  Here are some examples (none of which work as custom URLS on dashboard tiles, but do all work as URLs set for some text with-in a text tile:

?filter=Business%252FBusinessCode%20eq%20%27ANZB%27

?filter=BusinessUnits%252FBUCode%20eq%20%27AESU%27

?filter=Programs%252FPgmCode%20eq%20%27FIWG%27

by Tas Frequent Visitor
yesterday

@v-qiuyu-MSFT,

 

I think I may have found an answer, but it took some trial and error. First I thought what if I edit the tile custom URL and remove the URL formatting so that it is saved in the tile URL field as:

?filter=District/District eq 'FD - 01'

?filter=Business/BusinessCode eq 'ANZB'

?filter=BusinessUnits/BUCode eq 'AESU'

 

I did this and it worked, but I had also (so I could easily see the result) set the Custom URL to open in a different tab (using Open custom link in the same tab? = No).  The system applied the filter to the report.

 

So then I removed the setting for new tab (Open custom link in the same tab? = Yes), and it stopped working in every case.

 

I then reverted to the formatted URL in some cases, with variations set to Open custom link in the same tab?= No and = Yes, and found that in all cases (whether the tile custom URL was formatted or not), that if the setting was Open custom link in the same tab? = Yes (ie same tab), then the filter does not apply, but if the URL is configured for Open custom link in the same tab? = No, then the filter is applied.

 

So as far as I can tell, this is a confirmed "bug", though I did not find anything in the documentation that discusses using filters in tile custom URLS.

 

It is nice to know that from a readability perspective, the custom URLS can be saved without the URL formatting. This makes them easier for an editor to read, and to change if required.