BUG in January, 2017 release: can't update a report from Desktop to Service

Status: Delivered
by pwickwire Frequent Visitor on ‎01-10-2017 02:02 PM

In the new January, 2017 release, I get a "Report has already been published" error message when I try to use the PUBLISH option to Update a report that exists on the Service from Desktop.

 

- Steps:

--I updated a report in Desktop that had been previously published to the Service.

--I selected the PUBLISH menu option in Desktop

--I selected MY WORKSPACE (where the report was located)

--I received an error "Report has already been published" and the update failed.

 

I've tried with several different reports both with the Service running and with the Service not running.  I've also exited Desktop and restarted it and repeated the operation.  In all cases, I got the same error.

Status: Delivered
Comments
by sebbyp Regular Visitor
on ‎01-15-2017 07:35 AM

i am having the same issue for the past few hours.  I made some minor changes to a desktop pbix file and when i publish to online to service the loading icon just keeps on spinning forever.  I tried signing out and then in and still the publishing icon just keeps spinning.  Argh!!!! theres nothing like working on the weekend to then get hit with an issue like this!

by nsagrawal Visitor
on ‎01-15-2017 09:59 PM

Hi,

 

 

Please download the new released Power BI Desktop, this issue should be fixed with this new version.

https://www.microsoft.com/en-us/download/details.aspx?id=45331

 

once you downloadedthe new version and installed, please logout from power BI Desktop and login again, then i am hoping it will resolved your issue, this works for me.

 

Thanks

Naresh

by guavaq Super Contributor
on ‎01-15-2017 10:19 PM

Anyone experiencing issues when opening a file that connects to a local file on SharePoint?

 

When I open the file it appears as if it has lost all the mappings to my measures. 

 

In values box it says "This field can't be used since it is invalid". 

 

The measures are there, and if I drag the same measure into the Values again it then works. 

by iamshaziiwork Frequent Visitor
on ‎01-23-2017 09:32 AM
Hi guavaq, I'm experiencing this issue, i had to manually put back all the fields and measures so that the visualizations would show up properly again Hopefully there will be some work to validate the reasoning behind this issue because this didn't happen on previous updates and it would be very cumbersome to manage if we had to redo "all" the dashboards in the whole organization at each update... Smiley Wink Thanks
by guavaq Super Contributor
on ‎01-23-2017 01:29 PM

Hi there @iamshaziiwork, there was an update to the Power BI Desktop on 20 January 2017.

 

I have downloaded and installed this updated version and I am no longer getting that error.

 

So install the latest version and see if it resolves your issue.

 

Regards

Gilbert

by iamshaziiwork Frequent Visitor
on ‎01-23-2017 01:33 PM
Hello @guavaq! thanks for the info, i did download the new update and it's now working!! so awesome!!
by Moderator Vicky_Song
on ‎01-25-2017 06:11 PM
Status changed to: Delivered
 
by saqib_javed Occasional Visitor
on ‎05-21-2017 02:36 AM
issue not resolved even after updating to the latest version
by froilan Occasional Visitor
on ‎05-22-2017 04:59 AM

I'm having similar problem just now. I click publish and there is no action taking place.  Your help will be highly appreciated. i did sign off and sign and switch account but still no effect.  any help?

 

thanks a lot.

froilan