Reply
Regular Visitor
Posts: 37
Registered: ‎06-09-2016

Problems running On-Premise Gateway

I am trying to troubleshoot some problems with a query when I refresh my report through the on-premises gateway. I've installed the March update of the gateway and turned on verbose logging, hoping to capture the query that was being executed. After running the refresh, I exported the log files to a zip file.

 

But I don't find the query anywhere in the files. And the log files are pretty cryptic. Does anyone have information on the format of the log files? Or better yet, a PBIX file to analyze them? I've tried Rui Romano's pbix for Desktop log files and reviewed Chris Webb's blog on the same subject, but every row throws errors - the formats are evidently quite different. I've also searched the community, googled it, etc. with no luck.

 

Any help on interpreting the on-premises gateway log files - particularly the new release with verbose logging - would be appreciated.

 

Thanks,

 

Sam

Moderator
Posts: 2,483
Registered: ‎03-10-2016

Re: Problems running On-Premise Gateway

[ Edited ]

Hi @SamTrexler,

The blogs you refer to introduce the way to analyze Power BI Desktop trace log file and tune the query executed in Power BI Desktop,  I am afraid that the blogs do not apply to on-premises gateway log.

 Moreover, according to my knowledge, we are not able to directly capture executed query in on-premises gateway log. What error message do you get when you refresh reports in Power BI Service?

Thanks,
Lydia Zhang

Regular Visitor
Posts: 37
Registered: ‎06-09-2016

Re: Problems running On-Premise Gateway

Hi v-yuezhe-msft, thanks for the reply. 

 

I am not receiving an error when refreshing reports, the on-premise gateway is delivering results. However, I need to dig into the query and try to tune it. And I am referring to the Power BI Gateways–March Update blog post on March 14, 2017 by Dimah Zaidalkilani, Program Manager - specifically, this part:

 

Verbose Logging.PNG

 

I see that this includes a lot of lines in the log file labelled "Verbose", but I don't see any logging of "queries and their timings". And I don't have any information on how to interpret the logs to help me tune my reports.

 

Thanks for your help,

 

Sam

Moderator
Posts: 2,483
Registered: ‎03-10-2016

Re: Problems running On-Premise Gateway

[ Edited ]

Hi @SamTrexler,

Have you restarted gateway after enable verbose logging?

Also as per this article, you can get details about slowing queries after changing the EmitQueryTraces value from False to True in the Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.dll.config file and changing the TraceVerbosity value from 4 to 5 in Microsoft.PowerBI.DataMovement.Pipeline.Diagnostics.dll.config file?



Thanks,
Lydia Zhang