Reply
Frequent Visitor
Posts: 4
Registered: ‎01-18-2016
Accepted Solution

Lab 1 after appending I get the following error ......

"[DataFormat.Error] We couldn't parse the input provided as a Date value."

 

So when i check to see the list of countries, I only see Canada. I have done these steps several times and still run into the same error. As a result my answers to the Lab Questions end up being incorrectCapture.PNG


Accepted Solutions
Frequent Visitor
Posts: 3
Registered: ‎09-25-2016

Re: Lab 1 after appending I get the following error ......

I was having same problem but I found the solution.

 

The problem:

 

The headers records from the international sales query that were inserted in the load process

 

Solution:

  • Load the folder with the Csv per country
  • Edit the International sales query
  • After loading the folder and before converting the data type to date, go to the country column.
  • Filter so that you exclude "Country" from the filter. Deselect it from the drop down. The fields should parse now.
  • Go on with the exercise and convert the date field to Data Type Date.

 

I think that the conversion failed because encountered a non date format in the records. Instead of Power BI ignoring it it just stopped the query there.

 

Let me know if it works for you.

 

View solution in original post


All Replies
Moderator
Posts: 22
Registered: ‎01-06-2016

Re: Lab 1 after appending I get the following error ......

My guess is that you are not using EN-US locale. You need to change this in PBI settings before connecting to the data.

Frequent Visitor
Posts: 4
Registered: ‎01-18-2016

Re: Lab 1 after appending I get the following error ......

How do i do that? Also is it possible for me to get an email notification when there is a reply to my question?

Frequent Visitor
Posts: 4
Registered: ‎01-18-2016

Re: Lab 1 after appending I get the following error ......

I manged to figure out how to access the locale and it is US English in the query. So that is not the issue.

 

USEnglishLocale.png

Frequent Visitor
Posts: 5
Registered: ‎11-04-2015

Re: Lab 1 after appending I get the following error ......

Can you please send a frown from Power BI Desktop so that we can look at what's causing this error?

Frequent Visitor
Posts: 2
Registered: ‎02-11-2016

Re: Lab 1 after appending I get the following error ......

Hello all. I am getting the same error when filtering the date. It is happening only with the CSV file.

 

First I have installed the PBI in portuguese and after tried in english, but the error yet is happening. I already change the locate configurations too.

Due this I can't proceed with the LAB 1.

 

Can anyone help me?

 

Thanks in Advance.

 

Frequent Visitor
Posts: 2
Registered: ‎02-11-2016

Re: Lab 1 after appending I get the following error ......

The same is happening with me.


First I though it was due my PBI be in portuguese. So I have installed the english version and the error persist.
Even configurating the locate settings it is happening.

 

Can anyone help me with this?

 

Thanks.

Fernando Maximo Ferreira

Established Member
Posts: 138
Registered: ‎11-28-2015

Re: Lab 1 after appending I get the following error ......

I was hitting the same error DataFormat.Error on the Date column. I got around it by using the "Remove Errors" function.

Select the International Sales query, select the Date column, the click on Remove Errors (circled below). After doing this, you can apply the filter and continue.

 

Lab1DateError.PNG

 

Thanks,
Sam Lester (MSFT)

Occasional Visitor
Posts: 1
Registered: ‎07-05-2016

Re: Lab 1 after appending I get the following error ......

The actual solution to this is below (the instructions in the course are wrong and the previously suggested solution is not good as it may result to missing rows or wrong dates):

 

1. First, I'm not sure, but it seems to the problem is related to the locale settings of the Power BI -cloud. I have registered my user account and installed my Power BI to a Finnish (Finland) locale. 

 

2. You must stick with the original local (in my case Finnish -locale) in Power BI too, DO NOT change your locale even if the course instructions are saying so. 

 

 

3. When loading the data with Get source, use Publish -button once to check that you can succesfully publish the raw data sets to the cloud.

 

4. Go to edit the query after combining the binary files in Lab 1.

 

5. Select the "Date" -column by right clicking it and use the "Change type" > "Using locale" and enter "Date" and "English (United states)" to the boxes (this is the original locale of the data in the column)

 

6. Then apply & close and everything should go smoothly without errors and your data is still completely correct

 

4. Right 

Frequent Visitor
Posts: 2
Registered: ‎07-24-2016

Re: Lab 1 after appending I get the following error ......

Very frustating and doesn't help me get the right answer in excersice two. I have no control over this and think this is an ill prepared lab!!!