Reply
Highlighted
Frequent Visitor
Posts: 2
Registered: ‎03-12-2017
Accepted Solution

Debug Assert failed: Feature switches have not been registered

I apologize, this is also posted in the Services forum; realized this is the more appropriate forum for this topic.

 

I've started getting an error while using "Power BI embedded". When I try to view the report on the page I get this error dialogue:

 

pbierror.png

Debug Assert failed: Warning: Feature switches have not been registered yet so switch values may not be correct.

 

The dialogue appears three times then the report will display normally. The error seems to be coming from this file:

https://embedded.powerbi.com/13.0.1700.1355/scripts/powerbiportal.common.bundle.js

That's as far as I've gotten on tracking it down.

 

The embedded reports were previously displaying without error. The same pbix files open without error using desktop.

Any help would be appreciated. Thank you.


Accepted Solutions
gds Visitor
Visitor
Posts: 3
Registered: ‎03-14-2017

Re: Debug Assert failed: Feature switches have not been registered

Try to update power bi embbeded related dependencies. It will work

View solution in original post


All Replies
Frequent Visitor
Posts: 8
Registered: ‎03-12-2017

Re: Debug Assert failed: Feature switches have not been registered

getting exactly same error - something has broken in March Release. Someone in Microsoft needs to look at this urgently - this is breaking all embedded reports. 

 

Multiple people are reporting this.

Also posted at http://community.powerbi.com/t5/Issues/Error-Feature-switches-have-not-been-registered-yet-so-switch...

https://community.powerbi.com/t5/Desktop/Feature-switch-instance-is-not-initialized-yet/m-p/139350

gds Visitor
Visitor
Posts: 3
Registered: ‎03-14-2017

Re: Debug Assert failed: Feature switches have not been registered

Try to update power bi embbeded related dependencies. It will work

Frequent Visitor
Posts: 9
Registered: ‎11-08-2016

e depenRe: Debug Assert failed: Feature switches have not been registered

What does replace dependencies mean?? do i have to load the project again in VS and manage my NuGet packages and compile and re-deploy for each and every installatin i have? 


Is that an acceptable answer Microsoft? 

 

Please MS we need a professional answer on how to fix that issue in Deployment scenarios!

Frequent Visitor
Posts: 8
Registered: ‎03-12-2017

Re: e depenRe: Debug Assert failed: Feature switches have not been registered

everybody looking for a solution to this erroe - please see resolution on this thread http://community.powerbi.com/t5/Issues/Error-Feature-switches-have-not-been-registered-yet-so-switch...

 

seems to have solved issue for me. 

Please do share your perspective on thoughts shared on this other thread around overall state of Power BI Embedded, and if you also believe we should be getting better support from MS if we're to continue using this for real production scenarios.