Reply
Frequent Visitor
Posts: 4
Registered: ‎08-13-2015

"Do Not Summarize" missing

I asked a similar question with respect to the Power BI Service recently, but it turns out that I'm experiencing the same issue in the Desktop app.

 

In the documentation, you can find info about being able to treat numeric values as separate rows, without aggregating - a so called "Do not summarize" option: https://support.powerbi.com/knowledgebase/articles/471200-change-the-aggregation-in-a-chart-sum-aver...

 

However, when I'm looking at my own project, with data imported from SQL Azure, I can't seem to find that option anywhere. I reproduced the problem even with a simple Excel sheet as the data source, so it doesn't seem like a bug in the Azure SQL connector : 

 

 

 

If this feature wasn't implement yet or was removed for some reason, how can I find out when to expect it back? The lack of it results in scatter plots being pretty much pointless.

Super Contributor
Posts: 3,495
Registered: ‎07-11-2015

Re: "Do Not Summarize" missing

I have never seen this in the service or desktop, only in Excel PowerView

In Ohio? Check out the Columbus Azure ML and Power BI User Group (CAMLPUG)
In lieu of a kudo, consider donating to The Buckeye Ranch
Frequent Visitor
Posts: 4
Registered: ‎08-13-2015

Re: "Do Not Summarize" missing

[ Edited ]

It is only avaibale in PowerView (ie : Excel)

 

Workaround : flag colum as text in your query

"dirty" workaround : if you need to keep your column as number for other calculation, duplicate the column in your query and flag it as text (remember to order it by the numeric column ;-) )

Moderator
Posts: 195
Registered: ‎06-23-2015

Re: "Do Not Summarize" missing

No longer! You'll now see that option in Power BI Desktop as well!
New Contributor
Posts: 581
Registered: ‎08-27-2015

Re: "Do Not Summarize" missing

I haven't updated to the latest version and I still have it available in my desktop version. If I go over to the data model and click on one of my measures or on any item with the Sum symbol, I can go up to the top under the Data Tools Tab for Modeling and in the Properties box see "Default Summarization: Sum " with a drop down arrow. Then I click the drop down arrow it offers several aggregations along with the "Do not summarize."

If it is not there for you, it must have been lost in the most recent upgrade.

Occasional Visitor
Posts: 1
Registered: ‎01-24-2016

Re: "Do Not Summarize" missing

I was stuck on this issue as well until I found "Default Summarization: Do Not Summarize" under Modeling in PowerBI Desktop

Highlighted
Occasional Visitor
Posts: 1
Registered: Monday

Re: "Do Not Summarize" missing

I can set the Default Summarization to "Don't summarize", but it still doesn't seem to allow a scatter plot that plots every item in a field. When creating a scatter plot with 'don't summarize' default for a field, it defaults to 'count' and 'don't summarize' on the Axis menu isn't there. I'm assuming "don't summarize" isn't supported for lots of specific charts. I can get 'don't summarize' to work on the same data in a table. 

 

Does anyone know how to get it in a scatter plot?