Reply
Frequent Visitor
Posts: 13
Registered: ‎01-10-2017
Accepted Solution

Filled Maps not working at all- please assist

I was working with the Filled Map Visual yesterday, mapping out zip codes in OH, to see one of my branches coverage areas.

I refreshed the data several times, with no issues.

I added a few zips, and refreshed, and the next thing I know, the visual isn't mapping over half the zips in the list.

I figured, just close out and try again.

Well, closing out became re-starting the computer, and eventually giving up.

 

Today, I pulled the zips of a totally different branch, in a different state, and mapped out it's zips. Now, the data won't appear at all.

I went back to my data from yesterday, and it will map out the same as the day before, just a handful of the data, but not all.

I have also tried the Bubble map, and am getting the same thing, which would make me believe that there is something wrong with my data. But how can data work one moment, half work another moment, and then not at all?

 

What are some issues that would cause this?

 

The more I use the filled map visual, the less I like Power BI. Not only do my maps often display with holes in the zips (meaning that the shape of the zip code presented by the filled mpa visual is incorrect). I've raised this issue before, but it is still a problem.

 

For users that deal with coverage areas, and needing to see accurate data, this visual falls drastically short compared to the old MapPoint program. When checking around in the forums and help videos, it seems this visual is overlooked as a valuable one. 

 

Please assist. Thank you.

 


Accepted Solutions
Frequent Visitor
Posts: 13
Registered: ‎01-10-2017

Re: Filled Maps not working at all- please assist

I figured it out. It's a very round-about way to handle it, but I fgured it out.

 

Instead of doing a Heirarchy with the country code, here's what I had to do:

 

Create three columns:

1. Country Code (in my case- USA)

2. Divider ( put a comma and a space- ", ")

3. Zip (enter your 5 digit zip code as text with the lead 0 there)

 

Then use the Concatenate Formula to combine the three columns

Name this Column "Postal Code"

 

Then import your data, and Use Modeling to make the Postal Code column "Postal Code"

 

When I mapped my Boston area zip codes in this fashion, the map comes out correctly.

 

Again, a pain, and it seems there should be a MUCH better way to handle zips beginning with a 0, but whatever, I got it to work, that's all that matters.

 

Thanks for everyone's help,

JCC

View solution in original post


All Replies
Super Contributor
Posts: 3,562
Registered: ‎07-08-2016

Re: Filled Maps not working at all- please assist

@JCLink8888

 

Could you please provide some data to repro this issue?

 

Best Regards,
Herbert

Moderator
Posts: 246
Registered: ‎03-02-2016

Re: Filled Maps not working at all- please assist - Status changed to: Needs Info

 
Frequent Visitor
Posts: 13
Registered: ‎01-10-2017

Re: Filled Maps not working at all- please assist

Is there a place to send my example to? I do not want to post my company data on a public forum.

Super Contributor
Posts: 3,562
Registered: ‎07-08-2016

Re: Filled Maps not working at all- please assist

@JCLink8888

 

You can upload the example to online file service like OneDrive and send share link to me through private message. Or you can send mail to me directly (v-haibl@microsoft.com)

 

Best Regards,
Herbert

 

 

Frequent Visitor
Posts: 13
Registered: ‎01-10-2017

Re: Filled Maps not working at all- please assist

Herbert figured out that the problem was that I needed to update to the latest BI.

Not sure why the recent update was causing this issue, but my maps are working again.

 

I'm finding other problems now- like USA zips that begin with 0 mapping in Australia.

 

JCC

Super Contributor
Posts: 3,562
Registered: ‎07-08-2016

Re: Filled Maps not working at all- please assist

[ Edited ]

@JCLink8888

 

Please check the zips shown in PBI Desktop, do they have 0 at the beginning? If not, try to create a text column with formula as below. And drag this column into Location field.

 

Column =
CONCATENATE ( "0", Map[Postal Code] )

 

Best Regards,
Herbert

Frequent Visitor
Posts: 13
Registered: ‎01-10-2017

Re: Filled Maps not working at all- please assist

Hey Herbert, 

 

It is still not working for me. 

 

I'm trying to attach a screenshot on here, that shows my zip column as a text column in Excel, and how BI is importing the data.

 

Is there a way within BI to adjust the column to get that lead 0?

 

Thanks,

JCC

Frequent Visitor
Posts: 13
Registered: ‎01-10-2017

Re: Filled Maps not working at all- please assist

I figured it out. It's a very round-about way to handle it, but I fgured it out.

 

Instead of doing a Heirarchy with the country code, here's what I had to do:

 

Create three columns:

1. Country Code (in my case- USA)

2. Divider ( put a comma and a space- ", ")

3. Zip (enter your 5 digit zip code as text with the lead 0 there)

 

Then use the Concatenate Formula to combine the three columns

Name this Column "Postal Code"

 

Then import your data, and Use Modeling to make the Postal Code column "Postal Code"

 

When I mapped my Boston area zip codes in this fashion, the map comes out correctly.

 

Again, a pain, and it seems there should be a MUCH better way to handle zips beginning with a 0, but whatever, I got it to work, that's all that matters.

 

Thanks for everyone's help,

JCC