Reply
Frequent Visitor
Posts: 7
Registered: ‎12-19-2016

Error configuring the Power BI Analysis Services Connector

Hi All,

 

I am tring to connect Microsoft analysis services in Power BI. but i am  getting below error 

Unable to connect: We encountered an error while trying to connect to in-bisqlvm001. Details: "Username needs to include a domain. Please use the format user@domain or domain\user and try again."Hide details

Activity ID:bf7a4081-ec40-3b18-e5a4-e02150860320
Request ID:d7df8725-fd67-4ee9-ac69-86cabb661824
Cluster URI:https://wabi-us-north-central-redirect.analysis.windows.net
Status code:400
Error Code:DM_GWPipeline_Gateway_BadUsernameFormat
Time:Mon Jan 02 2017 10:25:17 GMT+0530 (India Standard Time)
Version:13.0.1700.872

MSAS.png

Thanks,

Swetha.

New Contributor
Posts: 465
Registered: ‎04-21-2016

Re: Error configuring the Power BI Analysis Services Connector

[ Edited ]

Hi @SwethaVitta,

 

As error message, you need to indicate the server name/server ip. If you have multiple SSAS instance, you need specify instance name. something like: servername or servername\instancenameofssas (my ssas server is: GA928615EB)

 

And you should try your usename with: domain\username (e.g: GA\pbix - my domain is GA, user: pbix)

 

Screenshot 2017-01-02 21.10.43.pngScreenshot 2017-01-02 21.10.54.png

 

 

And one thing that for another topics similar to gateway or configure concern, you could post in Desktop or Service area instead of Feedback area.Smiley Very Happy

Frequent Visitor
Posts: 7
Registered: ‎12-19-2016

Re: Error configuring the Power BI Analysis Services Connector

Hi @tringuyenminh92,

 

Thanks for reply. but i tried all the combinations what you mentioned in this case my machine name is in-bisqlvm001 where my ssas is installed and i have only  one instance. i am still getting the same error. is there any thing i need to configure apart from these.

 

Thanks,

Swetha

New Contributor
Posts: 465
Registered: ‎04-21-2016

Re: Error configuring the Power BI Analysis Services Connector

[ Edited ]

Hi @SwethaVitta,

 

Did you provide domain in the username input? Cause it needs domain\username for SSAS sources. As my observation, you are using vm, did you configure domain for your vm?

Frequent Visitor
Posts: 7
Registered: ‎12-19-2016

Re: Error configuring the Power BI Analysis Services Connector

Yes i gave domain name as domain\Administrator @tringuyenminh92

Frequent Visitor
Posts: 7
Registered: ‎12-19-2016

Re: Error configuring the Power BI Analysis Services Connector

yes i installed ssas in vm and all my machines are in same domain

New Contributor
Posts: 465
Registered: ‎04-21-2016

Re: Error configuring the Power BI Analysis Services Connector

[ Edited ]

Hi @SwethaVitta,

 

You are using AS connector, did you try to remove and install enterprise gateway and configure? Cause AS connector ran out of serivce.

Frequent Visitor
Posts: 7
Registered: ‎12-19-2016

Re: Error configuring the Power BI Analysis Services Connector

Thanks @tringuyenminh92 the issue got resloved i used server name as domain.